Vaccine: ftp error 425

In the Enumeration phase, I try to ftp to the 10.10.10.46 server. It succeeds but I get error while doing directory listing. I can confirm the vpn connection is proper, I have downloaded thepack newly and stopped/started multiple times. Can anyone help here?

ftp 10.10.10.46
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>
ftp> dir
200 PORT command successful. Consider using PASV.
425 Failed to establish connection.

Tagged:

Comments

  • Hi Kartym,

    a FTP session uses 2 TCP connection:
    1st -> FTP commands and replies
    2nd -> Data

    I suggest to check if your firewall is blocking the data connection.

  • edited July 7

    Hi, @kartym

    you need to turn on the passive mode by typing just passive. Then you have to type dir. Hope it will work.

  • edited July 8

    I just wanted to say thank you @soumyadeep112 , After wracking my brains trying to figure out why i was having the same issue for the past few attempts.

    Applying the passive switch fixed the issue.

    I felt i kinda "cheated" myself by getting the backup.zip via a Filezilla client but it was irritating me that i couldn't get the ftp cmdline to work correctly.

  • Type your comment> @soumyadeep112 said:

    Hi, @kartym

    you need to turn on the passive mode by typing just passive. Then you have to type dir. Hope it will work.

    This worked perfectly well. Thank you @soumyadeep112 and @gproot

  • edited July 18

    HI all of you,

    passive mode works for me to execute the dir command. Unfortunately I get a Permission denied error when trying to get backup.zip. (passive and active mode)

    ftp> get backup.zip
    local: backup.zip remote: backup.zip
    local: backup.zip: Permission denied

    I allow ftp via ufw like so:

    sudo ufw allow ftp

    And I added a rule to open port 20 for the specific ip:

    sudo ufw allow from 10.10.10.46 proto tcp to any port 20

    Do I get this Permission denied because of my own configuration?

    EDIT: Oh my bad, I figured it out myself. I was inside my root dir, after changing to my workspace I could get backup.zip normally.

Sign In to comment.