Swagshop

13537394041

Comments

  • Am stuck with frog, my shell does not seem so execute, can somebody give a hint?

    keresh

  • Could someone give me a hint. I have created my own user and tried a exploit but the python is wrong. Should I use this exploit?

    OR am I suppose to find admin credentials somewhere?

    OSCP

  • Rooted! Thanks to @Hackbot1x, and so to return the respect, if anyone needed a nodge or hint, pm me. FYI: I learn many new things from this box, very challenging if you are not reading the exploit correctly. I struggle from the get-go but managed to access the A*** P***. Then got stuck there for days (esp. after the downloader was taken off), and read the forum here over and over and finally asked hint from @hackbot1x. Have fun with, don't let the frustration gets ya, you will succeed in the end.

  • edited September 2019

    any tips on the type of shell to use. I can run commands but not create reverse shell. Tried everything I can think of.

    OSCP

  • Actually blocked on Admin Pa***, can someone pm me for some hints ?
    Magento Connect disabled :x

  • @ankh2054 said:

    any tips on the type of shell to use. I can run commands but not create reverse shell. Tried everything I can think of.

    http://pentestmonkey.net/cheat-sheet/shells/reverse-shell-cheat-sheet
    Try this page, extremely useful resource

    clubby789

    • GCIH
      If you need help with something, PM me how far you've got already, what you've tried etc (I won't respond to profile comments, or on box release night). And remember to +respect me if I helped you ; )
  • There is no Magento Connect Manager login page. I get '/downloader/ was not found... ' when I try to connect to it from the Magento Admin page's drop-down menu. I cant continue.

  • With all the pieces in place, this was indeed an easy root.

    Hack The Box

  • I can't seem to create my own creds, I can get in using the default creds that the exploit creates, (I'm guessing this is from someone else) but if I change the username to something else I can't log in even though the exploit says it worked

    Any hints for getting this working? I've tried a couple different copies of the exploit from exploitdb and github but have the same result

  • same as @kalq I think something is wrong, the /downloader/ page isnt working, rather the M*****0 c*****t M*****r gives an 404. @ch4p

  • You do not need the downloader page to accomplish the machine. @kalq @p5yph3r

    Look for another documented method of getting a shell.

    marlasthemage

  • edited September 2019

    Could someone nudge me over where to upload/how to get the reverse shell?
    Thanks, PM me!

  • Ok, got the user ...

  • edited September 2019
    Not do-able. Box is getting resetted constantly.
    No good day for e-commerce ;)

    Please folks, do not brute-force this poor server. No need!
  • I've been trying to get user access in 2 days, with no success.
    I successfully got in the admin panel in short time, then, I spend just so much time to use things that should have worked (according to previous comments in this forum):
    - tried to use the downloader -> it has been removed
    - tried the python script with the POST request -> getting the weird error with "tunnel = tunnel.group(1)".

    Honestly, this is getting just frustrating.
    If anyone has any idea of how to make work one of the mentioned things, please let me know

  • Same problem as above cant get the downloader to work or the POST. any ideas

    Hack The Box

  • Got user flag and I've been wrecking my mind for the past 2 days on getting root flag. Needs help...And i've got only a non-interactive shell. Suggestions on getting interactive shell will help me alot.
    HELP ME ON GETTING ROOT.TXT...Did everything that I knew...

  • Type your comment> @hackerg1rl said:

    Finally gotten root. if anyone need a little nudge, pm me

    Got a non-interactive shell...Any help would be appreciated on getting me root.

  • Alright Ladies and Gents, so I have a baseline shell. I am absolutely stumped on getting ROOT. I know I can s*** with vi but AHHHHHH, someone help LOL!

    Thanks in advance!

  • Im so lost about getting shell after 404 error. Please help! Thank you!

  • I got root, it's easy box, but the people here made it harder, I don't know why they keep reset it. for any help don't hesitate to PM/DM.

    N3v3r Giv3Up, 3v3ry th!ng !s p0ss!ble .

  • Type your comment> @mavs23 said:

    Im so lost about getting shell after 404 error. Please help! Thank you!

    What have you done so far? DM me if you need hints

  • Type your comment> @Freak2600 said:

    Same problem as above cant get the downloader to work or the POST. any ideas

    DM me if you need hints. But, downloader is not an option. It has been disabled.

  • Ah! It took me days to finish this. I wasted a whole day cause of a typo. Thanks to @NativePWN for spotting it.

  • I have done nothing. Tried enumeratin users, but giving false positivies. Pleases help! how to get admin panel.

  • edited September 2019

    Took user yesterday, which was nice.
    Now going for root.

    If anyone need a nudge, PM me.

  • Usered and rooted yesterday. Interesting box, feel free to pm me if you need help

    Hack The Box
    Pm me and tell me what you already have and where are you stuck. Feel free to give me some respect if I helped you !

  • Omg... Please stop resetting the box, frustrating..

  • This box is pretty frustrating as its constantly reset. There should be no reason to do this if you are trying for user or root. Trust me you dont need m***s****t for this just use step by step attack with credentials found to upload a s**** and then get user. The RCE's dont work and are rabbit holes, they my have worked in the past but dont work now.

  • edited September 2019

    Is it too much to ask for a more delayed reset like 10 minutes? Are the requests even inserted in a queue?

    St3veR0nix

Sign In to comment.