misDIRection

124»

Comments

  • Type your comment> @junkh3ap said:

    Type your comment> @ghostride said:

    For those getting HZ... instead of HTB..., it may be a file system case sensitivity issue.

    I got the same issue while using a Linux VM because the file system I unzipped the file to was a shared folder from my Mac OS host, which had a case insensitive file system. After unzipping to a case sensitive file system inside the VM instead, it worked

    Exactly this - thanks!

    Yes, unzip in linux.

  • I solved it with a bash inline, and neither extracted the contents from the zip archive. The tip is "order" with DIRirection in mind.

    Show +respect with who helped you out!
    https://www.hackthebox.eu/home/users/profile/61374

  • Loved this challenge. Puzzle inside a puzzle. PM for nudges/hints.

    Silv3rDawg23

  • If you get what looks like a flag out but get denied on the submission, have a closer look at what you tried to paste in.

  • Oh boy! I just realized that the difficulty of this challenge depends on the OS you are using.

  • Type your comment> @ShingoTamai said:

    The first approach that came to my mind was also the right one.

    But I banged my head on the wall for a couple of hours because I was lazily using Windows.

    It is important to have both upper case and lower case subdirectories present in the filesystem to be able to come up with the solution.

    When I have opened the zip file under Windows, I was seeing something like the following.

    E.g.:

    U:
    9
    20
    28

    When I decompressed the zip under Linux, things looked different.

    E.g.:
    u:
    20
    28

    U:
    9

    As you can see, the files are organised in a different way. I hope this helps.

    I did the same thing...USE LINUX TO DO THIS CHALLENGE! Super easy if you do.

    marlasthemage

  • importent :
    When i was acctualy unziped (with winrar) i got CAPITALS open as lowers ..

  • Not a difficult one, if you are stuck, go back to the start. Consider what you have and how those things may relate to each one.

    The end result will have the full flag (including HTB). Make sure you do this in a case sensitive OS, such as linux/macOS. ;)

  • It may happen that one loses the correct casing of directory-names when unzipping the archive that leads to scrambled data...

  • I need a nudge, I got a string but as others mentioned I get HZ... if i root Basically, I need a hand in the decrypt?

    could someone PM me please.

    guanicoe

  • edited March 23

    Overall I liked this challenge, not too hard and kinda fun. But there are a few mistakes you can make along the way that will turn this into a headache.

    Nudge:

    • Make sure you unzip the folder on a linux machine. If you don't Windows will collapse files into one another (For example folder Z/ and z/ will be combined ) and you will not be able to complete the challenge!! If you unzipped on windows restart the challange on a linux machine.

    • If you are stuck try installing tree which will display the contents of the directories recursively and might give you a better idea of what to do

    • Lastly, once you have an idea run with it and don't overthink the decoding

    PM me if you tried these and still can't figure it out

    GotRoot
    If I helped you out at all, feel free to click my badge and give +1 respect!

  • Man this challenge is pretty confused.

    PromeDNS

  • 1) unzip
    2) ls -R,
    3) try to notice a pattern with folders and character sets
    4) crack the cipher

  • edited April 17

    Its too easy friends .... you just need to encode this --> HTB -----> then you will found the pattern.

    Super Hint ! : the encode that you get shows the patern of folders sequence :wink:

  • Remind me that I'm still a NOOB for Linux text processing ^^

  • Kinda easy. Not possible on Windows, had to complete it in an ubuntu container. One liner was enough for this.

Sign In to comment.