Hint for HELP

1141517192029

Comments

  • If you want any help, you can pm me :D I got root :star:

  • edited March 2019

    finally ROOTED.....
    feel free to PM me for hints!!!!
    https://www.hackthebox.eu/profile/56044

  • edited March 2019

    Rooted :) user was a little bit tricky :B but root was simple :) . Awesome box! Feel free to PM me

    SiV4rPent3st

  • User & ROOT :smile:
    Reading through the comments I was confused about the time travel because for me it worked out of the box, and then I realized where I live :tongue:
    Nice box! :smiley:

  • Type your comment> @tobor said:

    I have rooted Help. However i set the time on my machine in order to do that thing. If someone has done that thing without setting the time on their machine would you mind sharing that knowledge with me

    You can always adjust the exploit to use the right time.

  • user and root. Fun but user was tricky.

  • Could I get some help on how to get the file uploaded?
  • Rooted PM for hints... :)

    image

    ------- MrBlackHat -------

  • Hello,

    Someone can give me clues to the root of the help box

    Greetings

  • The hints spread all over the thread should be enough to guide you on the right path, if that isn't the case I'm open for PMs.

  • edited March 2019

    Got user & root. Anyone want to PM on the port *000 route for finding creds? Not familiar with that language/framework.

    Hints for user:
    Make sure your time is automatic.

    For root: basic priv esc. Article below shows general steps, but the exploit won't work for this box.

    https://null-byte.wonderhowto.com/how-to/perform-local-privilege-escalation-using-linux-kernel-exploit-0186317/

  • edited March 2019

    Ofcourse a few minutes after i ask for help, i manage to upload a file...

  • Great box. Detail is everything.

    User had me stumped for days... "Try Harder" is an asset when approaching this box.

    Root, just follow VERY basic enumeration.

    The biggest takeaway and hint from this box for User and Root is: TRUST NOTHING!!!

  • edited March 2019

    hello everyone,
    who could help me take root?

    i'm get root!

  • Thanks for the box. As for the usual statistics in case anyone is interested: user flag took about 2 hours of on and off poking and figuring out a bunch of small problems to get it to work. Root flag took about 30 mins.

  • edited March 2019

    Got user, found creds for (I ASSUME based on the context) the service on port 3***. when I try to access M****** via command line, I get an error "Host Unreachable." Host is definitely reachable (I can still hit it in the browser), so I'm confused what else might be causing that error. Google hasn't been very helpful.

    Am I barking up the wrong tree with M******? Is there a flag/option I should be specifying? Is this possibly caused by another user borking the machine, and I should reset?

  • edited March 2019

    I have root as well, but I know nothing of Node and would appreciate a tip on how to properly get the creds from the high port. I've tried google but I can't make sense of how to use it. Thanks to anyone who wouldn't mind sending a pm.

  • Amazing machine! The port 3**** is very useful for the exploit to work!

  • Type your comment> @Nibodhika said:

    Damn, I spent too much time banging my head against the wall on some stupid mistakes. I went the easy (unauthenticated) route, since I couldn't figure out the high port endpoint, and after reading the code I'm not sure how I was supposed to discover that other than a wild guess.

    Hint for user: go read the code, seriously, pay close attention to it, don't trust the exploit documentation over what you're seeing, but the exploit code is correct.

    Hint for root: I hate typing in the wrong window almost as much as I hate Caps lock.

    This hint gave me the final clue for a happy ending. Thanks!!

  • I got user and root but I ended up not using Node at all; could someone PM how they did it? I'm curious what the other options are.

  • I just wanted to thank you guys for the hints. This is my very first attempt of solving this sort of challenges and every is new and confusing to me.

    I've currently managed to use the credentials, tomorrow I will continue exploring my options.

    I truly think that I won't be able to make and upload an exploit (never done that before) but I'm learning a lot, especially not to give up and keep trying everything I can.

    I'll try to keep an eye here to try to return to the community the help I've been granted!

  • I have identified the CMS. I have tested a few things from exploit-db and (regretfully) metasploit but it doesn't seem to work. Can someone DM me with a nudge?

    Hack The Box
    Follow me on Twitter: @C_3PJoe

  • edited March 2019

    Deleted post

  • Will the box be up for many more days? Got the CMS , clever name.

  • edited March 2019

    Going crazy for root...
    Maybe missing something in my enumeration. Although root is possible with kernel exploits, want to try without them.
    Please PM me any nudge/hint.

    Edit:
    Rooted!!! Overlooked simple enumeration

  • already spent 2 hours :( stuck on g*****l part. not able to create proper request in postman, Please PM any clues

  • edited March 2019

    Can whoever is resetting the box every few minutes please stop.
    Working on root enumeration and it keeps resetting .

    EDIT:

    Rooted, first box I've done on here. Great learning experience, thanks for putting it up.

  • FINALLY Finished

    User - was tricky ... read the github source code and ignore error messages.
    Root - known exploit

  • hey guys when I submit tickets I don't receive any email ? Is i am right direction ?

  • Hello I got this error
    Any hint ?
    [email protected]:~/Desktop# nc -nlvp 6392
    Listening on [any] 6392...
    connect to [10.10.12.27] from (UNKNOWN) [10.10.10.121]
    [email protected]:~/Desktop#

    I can't access...

Sign In to comment.