Official Armageddon Discussion

16781012

Comments

  • edited April 26

    Spoiler Removed

  • Rooted! Fun box, not too hard.

    Enumeration
    Basic enumeration should help you out just fine.

    Gaining access
    The name of the box is a great help finding your path towards access.

    User
    Enumeration is what helps. If you found some 'loot', where could you employ it and what might it bring? Use the loot to get some more loot. If this new loot goes beyond you, it is always useful to read the bible (The true light that gives light to everyone was coming into the world.)

    Root
    Straightforward enough. Stuck with a weird error? Perhaps the name you chose is the issue.

    image

  • edited April 27

    User was pretty easy. s*** crafted but after install nothing changed, dm hints?

    nevermind, got it

  • edited April 27

    Finished the root part with little effort, if you get stuck at running the craft, try to understand the error and follow it (change some thing in your craft).
    By the way, i force in the ssh with h****a, someone could give me hints to find another to get in with m****l ?? I try to watch the running service but there are no m****l process, then i tried to watch the service listening at lo******st but still find no way to get in. Thanks a lot for helping!!

  • edited April 27

    Hi

    Does anyone else experience connection problems with the box? It is super slow and always falls through. Would be very grateful on some tips how to improve the connection, as it is getting annoying.

    Disregard that :) Should have googled a bit harder regarding vpn issues.

  • edited April 28

    rooted, but no idea with the s*** service, people said there is an enum, but seems not work

    user: ml and ha also works

    Arrexel

  • Finally rooted this machine. The user flag was easy. But boy did the root kick my ass. Should have been studying today but instead spent the entire day trying to root this machine! Managed to get it just as I was going bed so I will sleep very peacefully tonight!

    Root hint:
    Look for a program around this exploit on the web. It’s dirty wink wink.

    The program doesn’t work. You’ll need to extract something from it and figure out what to do with it after that. Once you’ve figured out what to do with it, just log in...

  • On a second note. Email me if you need help. I know you can wait until it’s retired and find out, but it’s also good for you to find out and learn.

  • edited May 2

    Is anyone finding something strange going on with this box? I started it a few days ago and found a D***** installation - however when I look now I can't see a
    Drupal installation but I can see a W******** installation. I have tried resetting the box but it is still the same?

  • Hey all,

    I'm like 99% into getting root, i just need some help with the very last part of the privesc. I understand the parts but i do not understand the tools or the related exploit code enough to know exactly what to do next. I've tried googling around but I'm not really sure what to look for. I can list off what i've tried in a PM if anyone is around.

  • Update: I was able to figure root out on my own by going back to a certain blog post by someone who discovered a relevant exploit. Lists exactly how he CRAFTED it and our user has a specific ability we can use. My suggestion is to read this block post top to bottom, then look at the source code to see what it is trying to do.

    Notice, this exploit is failing because the /exploit/ itself is blocked, but because of the special permissions our user has we may just have what we need to circumvent the exploit and do waht the exploit intended anyways.

    I'm glad i dug deep into this and figured it out on my own, very rewarding.

  • Don't forget to reset your machine, it was help me with root

  • Spoiler Removed

  • Spoiler Removed

  • This box took me a lot of time. Most of that time was spent looking for the initial user creds after getting the foothold (since I wanted to avoid brute forcing). ParrotOS also slowed me down a bit on the priv esc. Overall, the technical difficulty is low for this box, but it can still take some time to find what you need. PM for a nudge if you need it.

  • Enjoyed this box, got the link between the name of the box and the exploit very quickly. Getting a stable shell was annoying so took a while to get the password from its storage spot. Root was fun, after I read the blog post, I knew which part of it I needed just took a little bit of working out how to craft the payload so the install didn't hang on target.

  • I really liked this box. It is quite easy to find the basic user. But as far as root is concerned, it is much more complicated, I have to do a lot of research. I'm still quite a beginner. I should advance in my learning before tackling the boxes. But hey, this one is very fun.

  • Really cool box, relatively straight forward. The name of the box is a pretty good hint for the initial access, and for root you need to GTFO and look online for it ;)

  • Pretty straightforward. Lost most of my time trying to get a real tty post-exploit, but ended up giving up. Closest I got was the error "out of pty devices".

    Anyone managed to get a shell as a****e?

  • Hello, could someone DM me to give me some nudge? I have the shell active, I have the ml creds and b************* username (not the pwd yet)
    I can't connect to the m
    l, it gives me an error that I'm not able to pass.
    Thanks

  • Type your comment> @N0ir said:

    Hello, could someone DM me to give me some nudge? I have the shell active, I have the ml creds and b************* username (not the pwd yet)
    I can't connect to the m
    l, it gives me an error that I'm not able to pass.
    Thanks

    Nevermind! Rooted :D

  • I spent half day trying to work around crafting my own payload for obtaining root... And you know what? I had correctly crafted payload at the beginning but it didn't work so I assumed it is wrong when it wasn't!
    So from above my most critical nudge is - make sure box is fresh (rebooted) before trying to execute your root payload ! Or check s*** ch***** log to see if someone before you already tried to load something wrong (which I guess is either breaking s*** or keep it hanging) - if so reboot the box; if log is empty then work away.

    User was pretty easy, just keep in mind how normally CMSs are being setup/configured and so you know where to look for the user.

    Root was pretty obvious after getting user and few minutes of research in google...

    pm me if need hints.

    al3ksec

  • hopefully not a spoiler but if you get the "Native builds aren't supported" error there is a good youtube video from 2017 that will help build with containers

  • got root .......................
    Very interesting box, specially the post exploitation part.

    User: Easy; if you find what component need to get exploited

    Root: Medium; Straight forward but you need to work on to get what you need !

    PM me for nudges ! :wink:

  • stuck at getting root user

  • Finally rooted my first box on HTB.

    Foothold: Do some enumeration and find out what is being used in order to help you find what is vulnerable

    User: Do some digging around. Look at what the website is being run by and how it saves information and find the source to your problem

    root: What are your options? What can you do with your options? Do your options work? If not, how are you able to fix it? Sometimes it might require to think outside the box and maybe craft your own.

    PM me for assitance

    Vibing Potato

  • I thought I saw a way to root the box on GTFObins using fpm to simplify the crafting process but I get an error "error: cannot perform the following tasks:...' , should it work or I really have craft the whole thing from scratch?

  • let me know if you need any hints
    i wont tell you the whole key
    ill give you only hints no spoilers

  • edited May 18

    got root

  • edited May 21

    Finally gain root access. Everything you need is already on this forum. Feel free to ask if you need help...

Sign In to comment.