Destination Host Unreachable

ping 10.10.10.27
PING 10.10.10.27 (10.10.10.27) 56(84) bytes of data.
From 10.10.14.1 icmp_seq=1 Destination Host Unreachable
From 10.10.14.1 icmp_seq=2 Destination Host Unreachable
From 10.10.14.1 icmp_seq=3 Destination Host Unreachable
From 10.10.14.1 icmp_seq=4 Destination Host Unreachable
From 10.10.14.1 icmp_seq=5 Destination Host Unreachable
From 10.10.14.1 icmp_seq=6 Destination Host Unreachable
^C
--- 10.10.10.27 ping statistics ---
7 packets transmitted, 0 received, +6 errors, 100% packet loss, time 6103ms
pipe

Seems that also when I use

sudo nmap -sC -sV -p- 10.10.10.27

I get

Starting Nmap 7.91 ( https://nmap.org ) at 2021-03-02 12:50 EST
Note: Host seems down. If it is really up, but blocking our ping probes, try >-Pn
Nmap done: 1 IP address (0 hosts up) scanned in 3.31 seconds

So I ended up reading in the forum https://forum.hackthebox.eu/discussion/2888/starting-point-htb, to do this instead and I get:

sudo nmap -sC -sV -Pn -p135,139,445,1433 10.10.10.27
Host discovery disabled (-Pn). All addresses will be marked 'up' and scan >times will be slower.
Starting Nmap 7.91 ( https://nmap.org ) at 2021-03-02 12:52 EST
Nmap scan report for 10.10.10.27
Host is up.

PORT STATE SERVICE VERSION
135/tcp filtered msrpc
139/tcp filtered netbios-ssn
445/tcp filtered microsoft-ds
1433/tcp filtered ms-sql-s

Service detection performed. Please report any incorrect results at >https://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 3.44 seconds

Is this connection supposed to be filtered? because when I go to the smbclient step I get:

smbclient -N -L \\\\10.10.10.27\\
do_connect: Connection to 10.10.10.27 failed (Error >NT_STATUS_HOST_UNREACHABLE)

Not sure what's going on. Could this be my firewall? I am using a Kali VM (QEMU, Virt-manager), my connection is set to Nat, and I can ping other machines just fine.

Tagged:

Comments

  • Have you confirmed you are connected to the HTB network?

    What does traceroute show?

    TazWake

    Note: https://www.nohello.com/

    Happy to help people but PLEASE explain your problem in as much detail as possible! If you say vague things like "It's not working", I cant help. This isn't Twitter so my DMs are always open.

  • What is the output of ip r? This will show the routing table. Look for tun0 :)

    I am always open to helping; however, please ensure you explain what you have tried first before asking for hints!
    Also, reps go a long way!

    Certifications: ITIL, eJPT, eCPPT (In Progress)

  • edited March 3

    This is what I get for each command: Hope you don't mind but I blocked out some of the ip, not really sure what would happen if anyone can see it.

    ┌──(kali㉿kali)-[~]
    └─$ ip r
    default via 192.168.. dev eth0 proto dhcp metric 100
    10.10.10.0/24 via 10.10.
    .* dev tun0
    10.10.14.0/23 dev tun0 proto kernel scope link src 10.10.**.***
    192.168.122.0/24 dev eth0 proto kernel scope link src 192.168.***.*** metric >100

    ┌──(kali㉿kali)-[~]
    └─$ traceroute 10.10.10.27
    traceroute to 10.10.10.27 (10.10.10.27), 30 hops max, 60 byte packets
    1 10.10.14.1 (10.10.14.1) 37.467 ms 37.147 ms 36.926 ms
    2 10.10.14.1 (10.10.14.1) 3067.989 ms !H 3067.787 ms !H 3067.567 ms !H

    ┌──(kali㉿kali)-[~]
    └─$ nmap -sC -sV -p- 10.10.10.27
    Starting Nmap 7.91 ( https://nmap.org ) at 2021-03-03 01:28 EST
    Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn
    Nmap done: 1 IP address (0 hosts up) scanned in 3.31 seconds

    sudo nmap -sC -sV -p- 10.10.10.27
    [sudo] password for kali:
    Starting Nmap 7.91 ( https://nmap.org ) at 2021-03-03 01:29 EST
    Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn
    Nmap done: 1 IP address (0 hosts up) scanned in 3.37 seconds

    OH yea also Thanks for taking the time!!!

  • Are you using a starting point VPN or the normal HTB VPN?

    TazWake

    Note: https://www.nohello.com/

    Happy to help people but PLEASE explain your problem in as much detail as possible! If you say vague things like "It's not working", I cant help. This isn't Twitter so my DMs are always open.

  • edited March 4

    Type your comment> @TazWake said:

    Are you using a starting point VPN or the normal HTB VPN?

    I'm using the HTB VPN; I do have anonsurf on my Host machine, but it's never activated.

    $ anonsurf status
    • tor.service - Anonymizing overlay network for TCP (multi-instance-master)
    Loaded: loaded (/lib/systemd/system/tor.service; disabled; vendor preset: disabled)
    Active: inactive (dead)

    I also did test to see if it was my VM by downloading the connection pack on my Host machine and running the nmap command for the right ip while using HTB VPN. Got the same Host seems down.

    Furthermore, I tested to see if it was the type of connection I was using, so I tested on both the VM and Host machine, seeing if direct wifi would make a difference compared to an ethernet connection to my Edgerouter ErX. Nothing different.

  • @Codemel said:

    Type your comment> @TazWake said:

    Are you using a starting point VPN or the normal HTB VPN?

    I'm using the HTB VPN;

    Which HTB VPN?

    You need to have downloaded a HTB Starting Point connection pack. It looks like you are connecting over the normal VPN, but I don't know Starting Point well enough to be sure.

    TazWake

    Note: https://www.nohello.com/

    Happy to help people but PLEASE explain your problem in as much detail as possible! If you say vague things like "It's not working", I cant help. This isn't Twitter so my DMs are always open.

  • Type your comment> @TazWake said:

    @Codemel said:

    Type your comment> @TazWake said:

    Are you using a starting point VPN or the normal HTB VPN?

    I'm using the HTB VPN;

    Which HTB VPN?

    You need to have downloaded a HTB Starting Point connection pack. It looks like you are connecting over the normal VPN, but I don't know Starting Point well enough to be sure.

    OOO THAT'S IT, I was using the regular one. Sadly I assumed and that set me baack.

    Thanks Alot!!!

Sign In to comment.