Official Omni Discussion

2456710

Comments

  • Type your comment> @sparkla said:

    Great "easy" box, wasted my Saturday night and a good part of my motivation for today.

    Damn right bro :D same here

  • I think I'm stuck in the same spot as others. I have a script, I can see the host file, ping myself, upload files, but anytime I try to execute an uploaded file it fails. Been at it for a few hours now between last night and this morning, not sure what I may be missing here.

  • edited August 24

    Same here, got both flags but can't really find a way to decrypt them. Also found a file i can`t read being NT/system user which really confuses me. Any ideas?
    EDIT: finally rooted. Turns out you don't really need to decrypt all the stuff since it's not actually "encrypted".
    Also pay attention to arguments of what you do, wasted a lot of time trying to get shell bc of it.

    nopej0hnson

    PM for nudges, will be glad to help you. But answering pretty slowly sometimes:P

  • edited August 23

    Got shell, enumerated nearly everything, couldn't find anything useful. Any kind of help is appreciated.
    Edit: I was enumerating whole time as low priv user, didn't pay attention to script options.

  • I'm stuck in the initial part, may I know if the ar*ser** is related?

  • Rooted! Interesting box with tech I've not really seen before. The user and root paths are quite similar which was a shame.

    alt text

  • edited August 23

    NVM

  • AttributeError: 'int' object has no attribute 'value'

    I have this error when i run the script anyone can help me in private message, please i try since this morning

  • Type your comment> @jedus0r said:

    AttributeError: 'int' object has no attribute 'value'

    I have this error when i run the script anyone can help me in private message, please i try since this morning

    I setup Parrot just recently and saw this thinking there was a mistake with the way Python came with the system. Not sure what's going on here either.

    Hack The Box

  • can anyone give some hints regarding foothold?

  • @parag1232 - google is your friend, search what things u find on what looks like IIS but isnt - you should find the script mentioned above,..

  • got the shell , can see both encrypted flags . a nudge would be appreciated

  • Type your comment> @m1r3x said:

    Got shell, enumerated nearly everything, couldn't find anything useful. Any kind of help is appreciated.
    Edit: I was enumerating whole time as low priv user, didn't pay attention to script options.

    Hmm. I might have to take another look

  • Nice box in the end. Learnt a few new tricks from this.

  • edited August 24

    Found a script that needs a mac address, is this the right path?

    Edit: nvm it was the wrong script.

  • I also have the same issue with the 'int' not having property 'value' with that script. tried with both python2 and 3 (adapted the print statements of the code for python3, and anything else i could find. I'm guessing some people got this working by the fact that people have rooted the box... not quite sure what is going wrong...

  • Type your comment> @watchdog2000 said:

    I also have the same issue with the 'int' not having property 'value' with that script. tried with both python2 and 3 (adapted the print statements of the code for python3, and anything else i could find. I'm guessing some people got this working by the fact that people have rooted the box... not quite sure what is going wrong...

    This is caused by the wrong library. Try enum34.

    alt text

  • Type your comment> @sm4sh0ps said:

    Type your comment> @watchdog2000 said:

    I also have the same issue with the 'int' not having property 'value' with that script. tried with both python2 and 3 (adapted the print statements of the code for python3, and anything else i could find. I'm guessing some people got this working by the fact that people have rooted the box... not quite sure what is going wrong...

    This is caused by the wrong library. Try enum34.

    Thankyou! I’ll try that tomorrow when I boot back up! Hopefully it works!

  • Not sure why I'm being PM'd for nudges so much on this box, but I have to apologize if there's a misunderstanding: **I didn't make the box yet. **

    I gave up frustrated after wasting my Saturday night on a really messed up python script, that obviously wasn't the right way. But because the box was labeled easy and google shoved it in my face over and over again I was led to believe initially that it must be the right way.

    If some people actually wanted to offer help to me: Thank you so much, this community is really great! :) Yet active machines aren't my nr. 1 priority right now, my OSCP lab has started today and I focus on retired machines (and brushing up essential skills and building new automation tools).

    Hack The Box

  • edited August 23

    finally solved it. thanks @sm4sh0ps for your help. I would've been weeks in this if it wasn't because of you. If anyone needs some nudges pm me.

  • I have a shell...finally went swimming to clear my head had it in mins
  • no clue where to even start on this one! I tried to dump some stuff from r** port but got no where. I can't anon auth with r**client either. cant fuzz on high port because of 401s. any nudges? should I chase after the application specific port? couldn't find anything about it other than backups/ :confused:

    zweeden

  • Type your comment> @zweeden said:

    no clue where to even start on this one! I tried to dump some stuff from r** port but got no where. I can't anon auth with r**client either. cant fuzz on high port because of 401s. any nudges? should I chase after the application specific port? couldn't find anything about it other than backups/ :confused:

    There is a hint on the form for inital foothold.

  • Type your comment> @m1r3x said:

    Type your comment> @zweeden said:

    no clue where to even start on this one! I tried to dump some stuff from r** port but got no where. I can't anon auth with r**client either. cant fuzz on high port because of 401s. any nudges? should I chase after the application specific port? couldn't find anything about it other than backups/ :confused:

    There is a hint on the form for inital foothold.

    as in the basic realm? i just get a basic auth popup? :/

    zweeden

  • Getting the correct users was frustrating, but the root and user path was really fun. I learnt something new today. Thanks to @root0verflow, @m1r3x and @sm4sh0ps for the different hints! :)

  • edited August 24
    Just now completed the machine. The machine is straight forward once you got the working script.
    For those who struggle on Flags, don't consider it as hash. It is encryption carried by PS. Google FU. ;)

    Hit me for cryptic nudges...

    A Chemist doing Penetration Testing - Check the Story here: BinaryBiceps

  • Type your comment> @zweeden said:
    > Type your comment> @m1r3x said:
    >
    > (Quote)
    > as in the basic realm? i just get a basic auth popup? :/

    dm> @zweeden said:
    > Type your comment> @m1r3x said:
    >
    > (Quote)
    > as in the basic realm? i just get a basic auth popup? :/

    nvm, it's no longer there. You need to do exploit search on IoT.
  • edited August 24

    rooted
    (New kind off box to learn new things)

  • Type your comment> @liquidrage said:
    > rooted
    > (New kind off box to learn new things)

    Hi, did you need to use the login page to get user/root?
  • edited August 24

    edited - comment removed - many thanks for the reminder @m1r3x

Sign In to comment.