Openvpn not connecting. Stuck at Initialization Sequence completed

I just got started here by going to the starting point section of the website. I have a kali machine running on virtualbox and I have the ovpn connection pack downloaded. Once I run "sudo openvpn crossbones.ovpn" It eventually stops running after a few seconds and stops at the line "Initialization Sequence Completed". After a few minutes of waiting, the program outputs "inactivity timeout (--ping-restart), restarting" and then ends up stopping once again at "initialization sequence completed". Anyone know how to fix this?

Comments

  • You use Kali and you're root by default. Why'd you need to use sudo, lol?

  • On Kali 2020 you aren't root by default.

    Note: I am not going to be available much in September.

    TazWake

    Note: https://www.nohello.com/

    Happy to help people but PLEASE explain your problem in as much detail as possible! If you say vague things like "It's not working", I cant help. This isn't Twitter so my DMs are always open.

  • Hey, what do you expect openvpn to output? Sound to me like it is up and running. Type ifconfig tun0 to check your IP.

    doxxos

  • Type your comment> @TazWake said:

    On Kali 2020 you aren't root by default.

    He doesn't use kali 2020

  • @ion0x0 said:

    He doesn't use kali 2020

    ok

    Note: I am not going to be available much in September.

    TazWake

    Note: https://www.nohello.com/

    Happy to help people but PLEASE explain your problem in as much detail as possible! If you say vague things like "It's not working", I cant help. This isn't Twitter so my DMs are always open.

  • Type your comment> @ion0x0 said:

    Type your comment> @TazWake said:

    On Kali 2020 you aren't root by default.

    He doesn't use kali 2020

    yes i do

  • Had the same problem 2 days ago. Sent Support all the log files/ovpn file, but it all looked good to them. Fixed it by switching from US to EU. Give it a try.

  • are you in the directory where the opvn file is saved??
    666snippet

    666snippet

  • @666snippet said:
    are you in the directory where the opvn file is saved??
    666snippet

    666snippet

  • It looked like openvpn was hanging at "Initialization Sequence Completed" for me, too. I opened another terminal window, ran sudo su, and was able to then run ifconfig tun0.

  • Type your comment> @ion0x0 said:

    You use Kali and you're root by default. Why'd you need to use sudo, lol?

    He may feel that his power is not enough, so use sudo

  • help me

    Hello, I can't connect to HTB Lab Access
    I receive this message from 'RTNETLINK answers: Permission denied
    Sun Jul 26 17:13:35 2020 Linux ip -6 addr add failed: external program exited with error status: 2
    Sun Jul 26 17:13:35 2020 Exiting due to fatal error '

  • @jjjmax said:

    help me

    Hello, I can't connect to HTB Lab Access
    I receive this message from 'RTNETLINK answers: Permission denied
    Sun Jul 26 17:13:35 2020 Linux ip -6 addr add failed: external program exited with error status: 2
    Sun Jul 26 17:13:35 2020 Exiting due to fatal error '

    You might need to run as root - sudo or su might help.

    If not, it is useful to know what commands you used.

    Alternatively this might help https://forums.openvpn.net/viewtopic.php?t=26388

    Note: I am not going to be available much in September.

    TazWake

    Note: https://www.nohello.com/

    Happy to help people but PLEASE explain your problem in as much detail as possible! If you say vague things like "It's not working", I cant help. This isn't Twitter so my DMs are always open.

  • i also can't connect to vpn its showing this messege

    Tue Jul 28 16:46:00 2020 OpenVPN 2.4.9 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 21 2020
    Tue Jul 28 16:46:00 2020 library versions: OpenSSL 1.1.1g 21 Apr 2020, LZO 2.10
    Tue Jul 28 16:46:00 2020 Outgoing Control Channel Authentication: Using 256 bit message hash 'SHA256' for HMAC authentication
    Tue Jul 28 16:46:00 2020 Incoming Control Channel Authentication: Using 256 bit message hash 'SHA256' for HMAC authentication
    Tue Jul 28 16:46:00 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]185.77.152.102:1337
    Tue Jul 28 16:46:00 2020 Socket Buffers: R=[212992->212992] S=[212992->212992]
    Tue Jul 28 16:46:00 2020 UDP link local: (not bound)

  • Here's my solution:

    sudo nano /etc/sysctl.conf
    net.ipv6.conf.all.disable_ipv6 = 0
    net.ipv6.conf.default.disable_ipv6 = 0
    net.ipv6.conf.lo.disable_ipv6 = 0

    Just to make sure:
    sysctl -w net.ipv6.conf.all.disable_ipv6=0
    sysctl -w net.ipv6.conf.default.disable_ipv6=0

    restart network:
    sudo /etc/init.d/networking restart

    Then:
    sudo su

    and then:
    openvpn yourfile.opvn (no sudo here)

    ch33rs.

Sign In to comment.