PSExec Module Not Found

Hey all

Anyone having any issues running impacket psexec?
When I run this command:
"~/impacket$ sudo python3 examples/psexec.py [email protected]"

I get this repsonse:
"Traceback (most recent call last):
File "examples/psexec.py", line 33, in
from impacket.krb5.keytab import Keytab
ModuleNotFoundError: No module named 'impacket.krb5.keytab'"

I've looked in the scripts, everything looks to be there.
This was downloaded from github yesterday, so everything is as up to date as can be.

Thanks!

Tagged:

Comments

  • Hi

    Try installing Impacket from the Impacket root folder.
    pip install .

    This resolved it for me.

  • Bro hi.

    i did this first apt-get install python3, after this i did pip3 install impacket.

    and launched the psexec.y again, this works for me. i found out this after read and search around 1 hour.

    i hope this help you

  • edited April 2020
    Hi,

    After $pip install .
    If the installation was done properly and still get an error.
    You may have old library.
    Go to impacket directory and type the following command.

    $sudo python setup.py install_lib

    If still doesn't work try $apt-get update , after above command.

    This worked for me.
Sign In to comment.