I can't connect to vpn in my kali linux #Help

Hi guys!

I was trying to connect to vpn with my kali linux, and i tried two times to regenerate and download my vpn file but it didn't work. The process always stuck in the same part. (I attached a picture)

Comments

  • [email protected]:~/Downloads# sudo openvpn 'kinos93(2).ovpn'
    Mon Dec 23 20:37:03 2019 OpenVPN 2.4.7 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 20 2019
    Mon Dec 23 20:37:03 2019 library versions: OpenSSL 1.1.1c 28 May 2019, LZO 2.10
    Mon Dec 23 20:37:03 2019 Outgoing Control Channel Authentication: Using 256 bit message hash 'SHA256' for HMAC authentication
    Mon Dec 23 20:37:03 2019 Incoming Control Channel Authentication: Using 256 bit message hash 'SHA256' for HMAC authentication
    Mon Dec 23 20:37:03 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]88.198.233.171:1337
    Mon Dec 23 20:37:03 2019 Socket Buffers: R=[212992->212992] S=[212992->212992]
    Mon Dec 23 20:37:03 2019 UDP link local: (not bound)
    Mon Dec 23 20:37:03 2019 UDP link remote: [AF_INET]88.198.233.171:1337
    Mon Dec 23 20:37:03 2019 TLS: Initial packet from [AF_INET]88.198.233.171:1337, sid=cfedad92 45467c82
    Mon Dec 23 20:37:03 2019 VERIFY OK: depth=1, C=UK, ST=City, L=London, O=HackTheBox, CN=HackTheBox CA, name=htb, [email protected]
    Mon Dec 23 20:37:03 2019 VERIFY KU OK
    Mon Dec 23 20:37:03 2019 Validating certificate extended key usage
    Mon Dec 23 20:37:03 2019 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
    Mon Dec 23 20:37:03 2019 VERIFY EKU OK
    Mon Dec 23 20:37:03 2019 VERIFY OK: depth=0, C=UK, ST=City, L=London, O=HackTheBox, CN=htb, name=htb, [email protected]
    Mon Dec 23 20:37:03 2019 Control Channel: TLSv1.2, cipher TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384, 2048 bit RSA
    Mon Dec 23 20:37:03 2019 [htb] Peer Connection Initiated with [AF_INET]88.198.233.171:1337
    Mon Dec 23 20:37:05 2019 SENT CONTROL [htb]: 'PUSH_REQUEST' (status=1)
    Mon Dec 23 20:37:05 2019 PUSH: Received control message: 'PUSH_REPLY,route 10.10.10.0 255.255.255.0,route-ipv6 dead:beef::/64,tun-ipv6,route-gateway 10.10.14.1,topology subnet,ping 10,ping-restart 120,ifconfig-ipv6 dead:beef:2::1055/64 dead:beef:2::1,ifconfig 10.10.14.87 255.255.254.0,peer-id 243,cipher AES-256-GCM'
    Mon Dec 23 20:37:05 2019 OPTIONS IMPORT: timers and/or timeouts modified
    Mon Dec 23 20:37:05 2019 OPTIONS IMPORT: --ifconfig/up options modified
    Mon Dec 23 20:37:05 2019 OPTIONS IMPORT: route options modified
    Mon Dec 23 20:37:05 2019 OPTIONS IMPORT: route-related options modified
    Mon Dec 23 20:37:05 2019 OPTIONS IMPORT: peer-id set
    Mon Dec 23 20:37:05 2019 OPTIONS IMPORT: adjusting link_mtu to 1625
    Mon Dec 23 20:37:05 2019 OPTIONS IMPORT: data channel crypto options modified
    Mon Dec 23 20:37:05 2019 Data Channel: using negotiated cipher 'AES-256-GCM'
    Mon Dec 23 20:37:05 2019 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
    Mon Dec 23 20:37:05 2019 Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
    Mon Dec 23 20:37:05 2019 ROUTE_GATEWAY 10.0.2.2/255.255.255.0 IFACE=eth0 HWADDR=08:00:27:be:43:2b
    Mon Dec 23 20:37:05 2019 GDG6: remote_host_ipv6=n/a
    Mon Dec 23 20:37:05 2019 ROUTE6: default_gateway=UNDEF
    Mon Dec 23 20:37:05 2019 TUN/TAP device tun0 opened
    Mon Dec 23 20:37:05 2019 TUN/TAP TX queue length set to 100
    Mon Dec 23 20:37:05 2019 /sbin/ip link set dev tun0 up mtu 1500
    Mon Dec 23 20:37:05 2019 /sbin/ip addr add dev tun0 10.10.14.87/23 broadcast 10.10.15.255
    Mon Dec 23 20:37:05 2019 /sbin/ip -6 addr add dead:beef:2::1055/64 dev tun0
    Mon Dec 23 20:37:05 2019 /sbin/ip route add 10.10.10.0/24 via 10.10.14.1
    Mon Dec 23 20:37:05 2019 add_route_ipv6(dead:beef::/64 -> dead:beef:2::1 metric -1) dev tun0
    Mon Dec 23 20:37:05 2019 /sbin/ip -6 route add dead:beef::/64 dev tun0
    Mon Dec 23 20:37:05 2019 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
    Mon Dec 23 20:37:05 2019 Initialization Sequence Completed

  • Aaaaand it's working. Try pinging one of the available machines.

    Razzty

  • Yes well, you're running it in foreground-mode, so it will just sit there once you've connected :) You can use openvpn -daemon kinos93.ovpn to background it automatically, or use the network manager (installed by default in Kali and Ubuntu) to handle it, by just apt install network-manager-openvpn-gnome and then clicking the network icon in the taskbar, going into the VPN settings, and importing your config-file.

  • try it with vpnbook.com new host

  • @kinos93 , when you do ifconfig, if you see a tun0 interface with a private address, that means you are ok

    Hack The Box

  • Hello everyone, I'm facing the same issue, I've tried everything (Switch to TCP 443, other servers 'vip & also free ones', regenerating the pack, reboot VM 'Kali' ...) but nothing work !!!
    Yesterday I've contacted the help desk but still waiting their response

  • Still waiting for support but I fixed it otherwise. Thank you anyway

Sign In to comment.