Hmmm cant connect to my open vpn

Ive been using trying to connect to my openvpn but when i do it doesnt work

[email protected]:~/Downloads# openvpn Verdatabo.ovpn
Tue Aug 13 05:17:33 2019 OpenVPN 2.4.7 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 20 2019
Tue Aug 13 05:17:33 2019 library versions: OpenSSL 1.1.1c 28 May 2019, LZO 2.10
Tue Aug 13 05:17:33 2019 Outgoing Control Channel Authentication: Using 256 bit message hash 'SHA256' for HMAC authentication
Tue Aug 13 05:17:33 2019 Incoming Control Channel Authentication: Using 256 bit message hash 'SHA256' for HMAC authentication
Tue Aug 13 05:17:33 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]198.27.104.112:1337
Tue Aug 13 05:17:33 2019 Socket Buffers: R=[212992->212992] S=[212992->212992]
Tue Aug 13 05:17:33 2019 UDP link local: (not bound)
Tue Aug 13 05:17:33 2019 UDP link remote: [AF_INET]198.27.104.112:1337
Tue Aug 13 05:18:33 2019 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Tue Aug 13 05:18:33 2019 TLS Error: TLS handshake failed
Tue Aug 13 05:18:33 2019 SIGUSR1[soft,tls-error] received, process restarting
Tue Aug 13 05:18:33 2019 Restart pause, 5 second(s)
Tue Aug 13 05:18:38 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]198.27.104.112:1337
Tue Aug 13 05:18:38 2019 Socket Buffers: R=[212992->212992] S=[212992->212992]
Tue Aug 13 05:18:38 2019 UDP link local: (not bound)
Tue Aug 13 05:18:38 2019 UDP link remote: [AF_INET]198.27.104.112:1337

Comments

  • edited September 3

    edit your ovpn file
    change proto from udp to tcp
    replace remote port to 443 from 1337
    change all tags from tls-auth to tls-crypt

  • I kept having this reoccurring problem too due to ipv6. It seems there is a problem with some ipv6 configurations only being partially enabled and messing with openvpn. The below worked for me:

    Edit /etc/sysctl.conf

    Set following to 0:
    net.ipv6.conf.all.disable_ipv6 = 0
    net.ipv6.conf.default.disable_ipv6 = 0
    net.ipv6.conf.lo.disable_ipv6 = 0

  • Hey,

    same problem here. Cannot connect to VPN, same error message. I'm not VIP user.

    Tested on both, Windows and Linux hosts - Kali Linux is running inside Oracle Virtual Box.

    @Sc15sploit Did you mean /etc/sysctl.conf on host or in the VM config?

    @Verdatabo Have you found the solution?

    Thanks for any tips / ideas how to solve this issue.

  • Type your comment> @gonzoman said:

    edit your ovpn file
    change proto from udp to tcp
    replace remote port to 443 from 1337
    change all tags from tls-auth to tls-crypt

    I have tried it...did not help.

  • edited September 23

    Sorry, I am an idiot and forgot to re-new my certificate after October 2018 - problem solved on my side.

Sign In to comment.