Getting errors with python exploits

Whilst following along with some ippsec videos, I seem to get errors with exploits where as ippsec doesn't and he hasn't changed the script at all.

Is it because ippsec has updated his python modules? And if so, how do I make sure that my python is up to date and has everything installed?

It always seems to stop on things that are correct but says they are incorrect syntax.

One example is 'Help'. The script doesn't work without editing many things whereas ippsec downloads it and executes it with no issues.

TIA.

Don't forget to +respect if I have helped you out at all.

Happy Hacking!

https://www.hackthebox.eu/home/users/profile/135164

Comments

  • Any idea which version of Python he's running it with? There are considerable differences between running a python script on Python 2.7 and Python 3.0

Sign In to comment.