Swagshop machines could read root.txt but no flag only text

In swagshop i got the user flag but when it comes to root i coulsd open the file but found only text and link without the flag
Tagged:

Comments

  • edited July 2019

    Did you try a reset?

  • yes i reset it and opened the root.txt but same result text and link with no flag

  • you should get the text and link but the very first line is the flag.

    if I was in your shoes and did not see the flag even after machine reset,
    I would connect to other server (us instead of eu and vice verse) to check if it is VM problem.

    tabacci

  • Had the same problem like you @vend3tta. Maybe you are not having a correct tty in your reverse-shell. Try to search for a python command to solve this. If it's still not working, redirect your cat on root.txt to an different file, read the flag and than of course delete the file as soon as possible to prevent others from reading it.

    Hope this helps

    v1p3r0u5
    If you need some help => 1) Your findings so far? 2) Your conclusions? 3) Your further ideas?
    RESPECT++ if I was able to help you! => https://www.hackthebox.eu/home/users/profile/139772

    No messages on the wall please and don't message me via HTB chat, please use the forum!

Sign In to comment.