OpenVpn exiting with fatal error (only EU vpn)

Hey everyone,

I'am experiencing problems with the openvpn for the free EU labs. When I try to connect to the vpn it instantly exits with the following error.

Fri May 3 10:40:14 2019 OpenVPN 2.4.7 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 20 2019
Fri May 3 10:40:14 2019 library versions: OpenSSL 1.1.1b 26 Feb 2019, LZO 2.10
Fri May 3 10:40:14 2019 OpenSSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
Fri May 3 10:40:14 2019 Cannot load private key file [[INLINE]]
Fri May 3 10:40:14 2019 Error: private key password verification failed
Fri May 3 10:40:14 2019 Exiting due to fatal error

I tried everything from the different posts here but nothing worked (regenerate a dozen times, pull-filters, switching).
But now comes the interesting part, it works if I use the free US vpn. I tried switching afterwards to EU again, but I still get the error. For the time being i could use the US vpn, but I would prefer to use the EU one again.

Does anyone have tips about how to solve this problem, or do I need help from an admin?
Thanks a lot!

Comments

  • Same happening with me too.

  • I have the same problem since yesterday afternoon. Does anyone here to help?

  • Ok, switch to US servers, regenerate the key and it will work....

Sign In to comment.