Curling

1131416181932

Comments

  • edited December 2018

    Heyo guys. I'm kinda stuck here. I was able to login to the Control Panel on the website. but I kinda don't know what to look for here. I tried uploading a PHP shell but whenever I try to access the file I get

    10.10.10.150 is currently unable to handle this request.
    HTTP ERROR 500

    Am I going in the right direction? If you have the time to help me out, I'd love the help c_c

    Edit:
    Thanks to @CaptainKeyes I was able to surpass my mistake and own user! My many thanks :3

    Now the fight continues to get root, Idk how the hell I'm gonna do it tho

  • aight, got both flags, tho the root shell is not necessary but love to know how ppl got it.

    I'm Usopp, the brave warrior of the sea.

    I'm a brave warrior of the sea and I have 8000 followers!

  • yea..if anyone can shed some light on how they established a root shell? (not just reading root.txt) - PM plez :)

  • Got reverse shell, now on box as www-data. Any tips on privesc to allow me to read txt files?

  • Hello,
    I'm currently stuck on the root flag, I got the user one and checked the files inside the a****_a*** folder and I'm pretty sure what those are about but I can't seem to find what to do with c***. Can anyone give me a hint towards what to do please?

  • Hi,

    Pretty stuck at the moment on the root flag, got user. Found the a_a folder, i know i have to do something with the i*** but cant find what to do with the c***. Can someone give me a hint?

  • Same here. Stuck at the root flag. Saw those two files. Not sure how to use them to get the root or root.txt. Any hints appreciated. Thanks.

    sesha569

  • edited December 2018

    (2) Did it in 4 days

    ASHacker

  • Rooted and done!

    While yes not the most difficult box it still had things in it that I didn't know too well and benefited from going through so my notes are improved and my confidence got a boost.

    Thanks to @L4mpje because I really enjoyed it

  • Got the root.txt. Not the root shell. Anyway thanks guys.

    sesha569

  • Got user quite easily..root.txt tooked a bit longer but I was "distracted" by that file in a...a...

    image
    Click here for HTB Profile: You are welcome to contact me for a nudge, but if I help you, please consider giving respect.

  • Can anyone please help me in getting reverse shell? I tried different methods in uploading the php shell but to no avail.. I have read all the comments and some people prefer to use other methods like code execution(?! if i'm right) in admin panel. Any nudge would be really highly appreciated. Thanks!!

  • ive gotten everything up to the priv esc without much trouble but i just cant seem to get out of my own way now. ive read through the source of everything just about and ive run a monitor script to check the ps. im pretty sure i understand whats happening, but i just dont see how i can make this work to my advantage. any hints would be very much welcomed and appreciated.

  • Anyone willing to answer a question about this box (In private so I don't have to put out any spoilers?)

  • got user.txt but struggling with root.txt, can someone PM me ?

    thx

  • Can someonen PM me for a little help with root.
    Thanks

  • PM me for hints on this machine if you weren't able to own root yet.

  • Got user but so stuck with that in*** and re**** file for root. Not to mention this is an easy box...Any hints in PM would be appreciated.

  • So I got the user, but don't have a clue to how i get root. I know it's about the two files there, i know what they are but can't exploit them.
    Don't know if i can get a hint or smth

  • Hello all,

    I got the user.txt, now im stuck trying to get root.txt and a shell
    Im looking at the ps -ef and seeing a reoccuring process over and over. and i see the a****-a*** but now i am stuck.
    Not sure how to use C*** either properly to take advantage.

    I am in desperate need of a hint to move forward, one to get the root.txt and another to get a shell

    thanks

  • Hello,

    I am not able to get a shell on machine. Whenever I run the shell code, it gives me 110 error and my listener doesn't capture anything at all. Can anyone give me hint from PM?

  • I'm also stuck on root.txt, have watched the a****-a*** and seen the commands being run, but unsure how to use C*** with the right i**** . It's definitely something simple that I'm not familiar with if anyone could please give me a hint in the right direction

  • i am able to get root flag and user flag,

    can someone please pm me with hints on how to get root shell. specifically commands im suppose to use. i already got the shadow file, i just now need to know how to replace it

  • initial foothold was just funny, actually laughed at it. I'm ashamed to admit that rooting the box took a lot longer than I expected. Sometimes you just get lost in the weeds and have to take a step back and don't overthink things. Hint for root: This machine is very aptly named!

  • I'm still stuck at getting shell. Can anyone PM me?

  • Need help with root if anyone can pm me.

  • Im getting stuck on root. Im pretty sure im suppose to use the files in the a*****-a*** and I think im suppose to use the c*** cmd in some way. Can anyone PM me and tell me if im on the right track or not?

  • See many asking for PM for hints, as I dont want to spoil and like to be effective I would prefer you PM me if you still need hints. But tell me where you are and what you have done so far.

  • GDXGDX
    edited December 2018

    Could someone enlighten me on how to get a root shell? I have a few concepts and tried them but they don't seem to work here.
    (So I owned root.txt already, just to make this clear)
    Nvm, got it.

  • edited December 2018

    Anybody else having problems with response times on this box?

    I've grabbed working creds and trying to take them further, but everything in the area when you can use them is SERIOUSLY slow to the point of being unusable.

    edit - it was still deathly slow after resets, but fine the next day

Sign In to comment.