Vpn connected but ping fails

edited October 2018 in VPN Connection

I regenerated the vpn key and get connected successfully (openvpn said :Initialization Sequence Completed) according to https://www.hackthebox.eu/home/announcements about vpn server upgrade, But I can't ping any machine and I do not have access to them. Any help!

Tagged:

Comments

  • Yes, I have seen the same. See if you have 'gateway' defined for the interface in question for VPN. Use ipconfig or ifconfig (depending your OS).

    In my case, once I manually defined (i.e. hard coded) the gateway's IP by looking other interfaces in the system, I was able to ping any machine that allows to do so. Here is system that I can successfully ping:

    C:>ping 10.10.10.77 | findstr loss
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    C:>

    Now for me the real issue is that I have to hard code gateway's IP each time I change my network (home vs. office). I can define multiple gateways but do not know how Windows picks which one to use. Least, I have a working solution.

    Good luck!

  • Back to gateway.... commenting my own issue and here is how it is working completely.

    Searched further on OpenVPN and gateway being blank. Someone pointed out that OpenVPN has to run as administrator. I did run once it as administrator and voila, gateway still being no value and able to ping HTB's machines. Next reboot the system and did ran OpenVPN as a standard login ( as I have been) and seems fine as well. There is no more hard coding IP needed.

    Writing this as someone has gone in the same situation like me. Here is POC:

    C:>ping 10.10.10.22 | findstr loss
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    C:>

Sign In to comment.