TLS handshake failed

I'm having this error when I try to connect :

TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
TLS Error: TLS handshake failed
Fatal TLS error (check_tls_errors_co), restarting

I tried both udp and tcp I executed the command as root and I have the latest version of openvpn yet can't solve the problem

help me please .. any help would be appreciated

Comments

  • edited September 2018

    Did u tried to redownload ?

  • and yes i redownloaded and regenerated the keys many times
    the same problem

  • I suddenly started having similar problems today in the middle of a session and can't reconnect.

    LegendarySpork

    my badge doesn't work, click on my profile if you want rank and stuff

    Taking a break from HTB through Dec 2019 in order to focus on other projects.

  • You need to redownload the VPN Key. On the left hand side of the HTB site (Not Forum), click on Access.

  • Yup, that's all it took. Thanks!

    LegendarySpork

    my badge doesn't work, click on my profile if you want rank and stuff

    Taking a break from HTB through Dec 2019 in order to focus on other projects.

  • TIL where the Announcements link is. Thanks

    LegendarySpork

    my badge doesn't work, click on my profile if you want rank and stuff

    Taking a break from HTB through Dec 2019 in order to focus on other projects.

  • edited October 2018

    @ippsec I downloaded a new VPN key and still nothing... I had been following the announcement. I even tried the new 443 stuff. Below is the output:

    EDIT:

    Turned off my VM and powered back up and now it works because CYBER.... 0.0 >.<

    "ClickmedotEXE"
    CISSP | OSCP
    arodtube

  • edited October 2018

    Regenerated keys, turned off/on VM - nothing helped. Still cannot connect to VPN :/

    Edit: One minute after I pressed the "Send", I connected...so it looks like posting in the forum is necessary step:))

  • I bet posting in the forum will not grant you extra access - automagically :)

    I was not able to establish my VPN session either until yesterday ( Yes, I am new here) and I tried both TCP and UDP ports and no luck.

    Just for the sake of curiosity, I killed anti-virus program that I have on my Windows system and there was no hand-shaking issue anymore. Getting there!

    Just to prove that anti-virus was blocking this communication and I re-installed anti-virus and things got toasted again.

    Next, I learned that in this ant-virus program, there is option to make exception on apps.
    I end up giving exception to all directory's programs/files where OpenVPN.exe is sitting.

    By doing so, I an able to make VPN session all ok. Though, I was still not able to ping any allowable (10.10.10.x) host. I dig deeper and found that there is not gateway IP defined. Once I hard coded the gateway's IP, I was able to ping. Here is POC:

    C:>ping 10.10.10.77 | findstr loss
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    C:>

    Well, my environment is Windows OS based. Yours may have different.

    Good luck!

  • Back to gateway.... commenting my own issue and here is how it is working completely.

    Searched further on OpenVPN and gateway being blank. Someone pointed out that OpenVPN has to run as administrator. I did run once it as administrator and voila, gateway still being no value and able to ping HTB's machines. Next reboot the system and did ran OpenVPN as a standard login ( as I have been) and seems fine as well. There is no more hard coding IP needed.

    Writing this as someone has gone in the same situation like me. Here is POC:

    C:>ping 10.10.10.22 | findstr loss
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    C:>

  • I downloaded the key and still nothing. sigh

Sign In to comment.